Did you knoow next to each category name there is a information marker ... (read more) close

ST-OC Shout out


Only registered users can send messages, register or login
  • adrianflux
  • akmotorsport
  • automodz
  • blueprint
  • justperformance
  • littledevil
  • ndtuning
  • tcharrison
  • treadmark
  • tripler

Topics in Category: Faults, Problems & Solutions

emo
Views: 135
Replies: 46
Preview
sbrace06's Avatar
Topic started 26 Aug 2017 17:56 by sbrace06
Hi guys, back from a long trip today and have a bit of an issue..car drove fine although there was lots of traffic so didn't get a chance to boot it at all for an hour or so. When I did, full throttle in third the car hesitated a moment then pulled fine, then juddered continuously. Boost gauge was...
sbrace06's Avatar
Last Post by sbrace06 06 Sep 2017 16:30
Quote: Mines done 74k now and has needed £1k worth of repairs this year... Boooooooo Working all good now though... Don't you still need a new clutch? Get someone to listen to the bell housing with the clutch engaged (in neutral, obviously), and with it disengaged. My knocking, which I thought was...
emo
Views: 134
Replies: 13
Preview
endo's Avatar
Topic started 09 May 2017 11:34 by endo
:( can anyone help . under acceleration i am getting a vibration through the car , same fault last year so changed both drive shafts (and they were both seized into the hubs , 20 ton press would not shift them , so also fitted new wheel bearings and both hub carriers :censored: :censored: ) the...
endo's Avatar
Last Post by endo 09 Jun 2017 10:03
now had there set of shafts including the originals that were changed , all with the fault , i cant see that!!!!!. anything else to look at ????? :nope:
emo
Views: 56
Replies: 5
Preview
Paul H's Avatar
Topic started 29 May 2017 16:33 by Paul H
Got a squeeking/squeeling noise when turning, is there something wrong with power steering? :unsure:
Paul H's Avatar
Last Post by Paul H 29 May 2017 19:24
Quote: Quote: Quote: Have you checked the obvious first...fluid? Checked, and ok it's not full to the top but would say there's 3/4 in it :unsure: wait till morning,then start car,turn wheel quite a few times lock to lock,then check resevoir and see if there are any tiny bubbles,that would indicate a slight leak,hard to...
emo
Views: 70
Replies: 9
Preview
tom.mcdaid's Avatar
Topic started 23 May 2017 16:03 by tom.mcdaid
:( I have a 07 225 st with mods done to it. Noticed that the last couple of weeks I've been using engine coolant every couple of days and mayo in the cap.had a good look over it and can't find any coolant leaks anywhere. I only do very short trips most days so put that down to the mayo in the cap at...
tom.mcdaid's Avatar
Last Post by tom.mcdaid 24 May 2017 07:13
That's what I'm thinking now I've possible bought the car like that only had it about 4 months dosnt smoke that much not on normal driving just noticed it once or twice puff of white smoke mainly on start up after a long drive when it's hot
emo
Views: 63
Replies: 4
Preview
Denners's Avatar
Topic started 23 Apr 2017 08:12 by Denners
Hi all Took the misses to work this morning no probs with the car, on the way back home when changing to 5th gear the car red lined with no change to speed, the same happened in 6th gear too, but whilst it was doing this the clutch pedal went straight to the floor and wouldnt come back up, this...
Casper's Avatar
Last Post by Casper 24 Apr 2017 05:43
I would recommend a and k motorsport, they sponsor us and do a complete kit with all the bolts etc Sent from my E6853 using Tapatalk
emo
Views: 378
Replies: 30
Preview
Denners's Avatar
Topic started 12 Feb 2017 21:08 by Denners
Hi all Over the past week my st car started cutting out whilst driving and at a standstill, it aslo occasionally seems to lack power and wont accelerate even with the pedal all the way to the floor. It also has been coming up with reduced acceleration, engine management fault and esp system fault. I...
Denners's Avatar
Last Post by Denners 05 Apr 2017 21:53
Well touch wood, after replacing the boost control solenoid, recirc valve, map and maf sensor the car seems better than ever at the mo, so much now that i've started to get the old clutch slip so looks like an excuse for an rs upgrade clutch
emo
Views: 129
Replies: 7
Preview
endo's Avatar
Topic started 20 Jan 2017 15:41 by endo
anyone had a problem with the headlight adjustment on the floor , adjust them last week and they adjusted themself back to the floor about 2 hours later, tried again and the same thing
Cymruambyth's Avatar
Last Post by Cymruambyth 25 Feb 2017 14:44
Quote: thank you for the advice , got back from working away and checked the arm and it was fitted wrong (arm to the front) :) Nice one mate :thumbsup:
emo
Views: 138
Replies: 8
Preview
Rein_ST's Avatar
Topic started 07 Feb 2017 17:41 by Rein_ST
Hi All Hope everyone is still doing fine. My car started having a jumpy idle on cold start up(engine cold not actual outside temp.) It starts fine and idles fine at about 1200rpms, but just as the revs drop to settle at the normal idle of around 800rpms it starts to jump from 800 to around the...
Rudders666's Avatar
Last Post by Rudders666 19 Feb 2017 14:43
Good news mate Sent from my F5121 using Tapatalk
emo
Views: 139
Replies: 20
Preview
Dastardly's Avatar
Topic started 04 Feb 2017 06:17 by Dastardly
Hi all This past week I've been feeling that the driver's seat rocks slightly back and to the left when I go round a corner to the right (at first I thought it was me going mad, but now I'm sure of it and I can make the seat wobble by pushing when the car is stationary). A Google search soon...
Cymruambyth's Avatar
Last Post by Cymruambyth 11 Feb 2017 15:58
Righto.
emo
Views: 168
Replies: 7
Preview
XenoouST's Avatar
Topic started 20 Jan 2017 09:13 by XenoouST
P0133 - Ox s cir slw resp 1 s1 Lambda sensor? Could anywayone shed some light before I splash out? Definately lambda? Not something else? I run a sports cat made by Dale from Bookface. less than 2 years and I'll be in a new car with warranty! >.<
sbrace06's Avatar
Last Post by sbrace06 23 Jan 2017 11:19
Quote: Lol we'll see. Does anyone know if the DS stratagem (old type) can read pending fault codes? I'm pretty sure it can mate
emo
Views: 167
Replies: 3
Preview
Dastardly's Avatar
Topic started 31 Dec 2016 19:42 by Dastardly
Happy New Year all A couple of months ago I added a Bluefin stage 1 tune to my stock ST225. I know Bluefin is small-fry to you guys running big power, but to me it felt great, particularly in third gear where a real increase in pull could be felt. However, over the last couple of weeks, whilst it...
Casper's Avatar
Last Post by Casper 04 Jan 2017 21:44
No problem :) Sent from my E6853 using Tapatalk
emo
Views: 110
Replies: 2
Preview
Rein_ST's Avatar
Topic started 22 Dec 2016 14:38 by Rein_ST
Hi I need some help. My car started jerking and then died after about 120km driving. If you then wait a few minutes you can drive again for about 20km before it does the same. I have plugged in my scanner and monitored fuel pressure. Fuel pressure at idle was sitting at 3.9bar and is constant...
Rein_ST's Avatar
Last Post by Rein_ST 30 Dec 2016 17:03
Hi Casper Yes had P0087 fuel rail / fuel system low pressure. Regards Sent from my D6603 using Tapatalk
emo
Views: 140
Replies: 1
Preview
judasp's Avatar
Topic started 13 Dec 2016 09:11 by judasp
Only just brought my St225 as my last car I had wrote off but noticed one little problem not a biggy tho one of my headlight jets don't work has anyone else had this problem or what to look at to fix this problem if I do eventually want to Sent from my E6853 using Tapatalk
Cymruambyth's Avatar
Last Post by Cymruambyth 13 Dec 2016 17:49
You`ll need it done eventually otherwise it`ll be an MOT fail mate.
emo
Views: 595
Replies: 10
Preview
Richst's Avatar
Topic started 14 Feb 2016 19:16 by Richst
Hi guys got a engine system fault come up today then it said acceleration reduced. Car is a 57 plate focus st. Whiling driving it didn't have much power then I turned the engine off then turned it back on again and the car is fine now. Any guesses to what's going on cheers.
Belly's Avatar
Last Post by Belly 27 Oct 2016 23:19
Did this sort the car as mine is doing the same thing it's had new maf and throttle pedal took it out tonight and only got 200 yards down the road and the engine malfunction light cam on and then acceleration reduced
emo
Views: 453
Replies: 8
Preview
Iain_sw's Avatar
Topic started 25 Jun 2016 16:19 by Iain_sw
hi guys, new to all this. Was hoping some of yous would be able to help me out. I have a standard st225 and over the last week have developed a loud whistle from the turbo/intake. At idle it is OK but when driving it starts as the turbo kicks in and stops about 3500-4000 rpm, slightly down in power...
Automodz's Avatar
Last Post by Automodz 11 Sep 2016 19:59
Quote: hi guys, new to all this. Was hoping some of yous would be able to help me out. I have a standard st225 and over the last week have developed a loud whistle from the turbo/intake. At idle it is OK but when driving it starts as the turbo kicks in and stops about 3500-4000 rpm, slightly down in power...
emo
N80 JCK's Avatar
Topic started 18 Jul 2015 20:45 by N80 JCK
Hi all a newbie here in desperate need of your vast advice please, how the story goes........ Put my focus St 225 pre facelift into my local tuning shop to have the front wheel bearings/hubs pressed out and longer wheel studs fitted for my rota grids to bolt on properly. Now I've got it back it...
Automodz's Avatar
Last Post by Automodz 11 Sep 2016 19:56
Hi there sounds like the bearings are damaged .. and there was no need to remove the bearing and front hub from the carrier to fit your studs tbh .. i have done this on a few cars for fitting slotted spacers and other wheels .. using 65mm studs there is away of doing it not sure where you are...
emo
Views: 750
Replies: 8
Preview
elle.cooper.121's Avatar
Topic started 22 Apr 2014 16:32 by elle.cooper.121
Hey Guys :) My turbo is whistling all the time, it only tends to happen when I'm in lower gears, when the turbo is boosting, but only just. It's quite loud and can be heard on the inside and outside of the car. It doesn't do it if the turbo goes past the 1/4 mark on the gauge. I've had various...
elle.cooper.121's Avatar
Last Post by elle.cooper.121 20 Feb 2016 11:53
Hey guys sorry I never posted a reply! Tbh, the problem kind of sorted itself! I posted this back in 2014 and I've still got the car and there are no issues with it. I don't think there was actually an issue with any of the pipes being split or anything more serious, I think it just turned out to...
emo
Views: 480
Replies: 6
Preview
endo's Avatar
Topic started 26 Jan 2016 12:44 by endo
help i am new to this forum, i have a 2007 focus st and i have a vibration under power in all gears , it does not get any worse the fast the car goes , but it does increase as the revs increase , if you sit at 70mph then it seems to cycle (comes and goes over about 1-2 seconds , seen other posts...
endo's Avatar
Last Post by endo 09 Feb 2016 13:07
thanks to all , looks like i will be changing the drive shaft shortly :(
emo
Views: 452
Replies: 11
Preview
alan.north's Avatar
Topic started 21 Oct 2015 13:32 by alan.north
Hey all my st has a knock if I flick steering and a notch in centre position when cold, is this common and what's the solution, do the racks give trouble I'm only have it a few weeks it's 07 st225 any advice thanks
Casper's Avatar
Last Post by Casper 30 Jan 2016 18:32
Breakers or ford mate Sent from my E6553 using Tapatalk
emo
Views: 348
Replies: 5
Preview
Rich's Avatar
Topic started 04 Jan 2016 10:46 by Rich
Focus ST3 2006 Fault codes B1318 B1601 U1900 U2200 U2197 Can anyone help please Sent from my iPhone using Tapatalk
Rich's Avatar
Last Post by Rich 07 Jan 2016 20:11
I think the battery had dropped too low with being sat for a couple of weeks with the wifi on the demon eyes.. Disconnected and all fine.. Sent from my iPhone using Tapatalk
emo
Views: 834
Replies: 15
Preview
Benzy50's Avatar
Topic started 01 Jan 2016 06:32 by Benzy50
Hi, I was having boost issue. The boost seemed really hesitant and only boosted half way. So I changed the boost solenoid to a heavy duty pumaspeed one and now After changeing it now it boosts to 12 psi but only for a split second then drops to no boost. Does anyone know why its happening I'm...
Benzy50's Avatar
Last Post by Benzy50 03 Jan 2016 20:33
True could be any one or all of these. Think il ring up jamsport tomorrow as I have herd there very good with the focus st and there not far from me. See if they will have a look fingers crossed it's not too expensive Sent from my C6603 using Tapatalk
emo
Views: 415
Replies: 0
Preview
moggs's Avatar
Topic started 10 Sep 2015 13:18 by moggs
HI im new here i have st225 with fault code p0133 i have chaged the lambda sensors both the maf map and boost solenoid . it all started when my oilfilter house diafram poped i replaced it and took it for a long drive and the light on the dash came on with codes p0133 and p2196 . But my fuel economy...
emo
Views: 426
Replies: 3
Preview
ru7hl355's Avatar
Topic started 12 May 2015 18:36 by ru7hl355
Hi guys, im hoping someone can help. i have had this annoying knocking/clunking noise for ages, it only appears when going left over rough'ish ground, the noise is coming from the drivers side and i can feel it slightly under my feet when it does it, the tyre on this side also appears to have worn...
SPIKE43's Avatar
Last Post by SPIKE43 12 Aug 2015 20:06
Could be a wheel bearing?
emo
Views: 465
Replies: 0
Preview
SPIKE43's Avatar
Topic started 12 Aug 2015 19:38 by SPIKE43
Hi Guys, can anybody help me please? I have a 2006 Focus ST, with the following mods: K & N Indution kit, Scorpion cat back exhaust and custom re-map. A few days ago i noticed that the car stutters when setting off and clears at around 3000rpm, Also the turbo boost is erratic and sometimes doesnt...
emo
Views: 321
Replies: 6
Preview
teggyst's Avatar
Topic started 12 Jun 2015 16:32 by teggyst
Hi there I was just wondering on some help my focus st 56 plate come up with the p2188 which said system too rich at idle bank 1 below minimum threshold previously set dtc any help much appreciated checked all pipe work can't find any leaks thank you
Casper's Avatar
Last Post by Casper 16 Jun 2015 06:38
I would think that code is from when u had the diaphragm go. That code brings on the eml when its set so it must of been a while ago Sent from my D6603 using Tapatalk
emo
Views: 679
Replies: 11
Preview
Moopheus's Avatar
Topic started 28 Apr 2015 21:49 by Moopheus
Anyone idea what this noise is? Recently had the oil filter housing changed so can't be that and the oil has also been changed recently. Going for a cam belt change tomorrow with a few other little jobs being done at the same time, but a separate...
Moopheus's Avatar
Last Post by Moopheus 12 Jun 2015 14:45
Well this solves the mystery of were the oil was coming from....... I've been searching for split hoses and all sorts (actually found 1 or 2 aswell) and been replacing things like the cam belt, water pump, pulleys, oil diaphragm getting it serviced, I've had it at so many garages and nobody could...
emo
Views: 592
Replies: 12
Preview
teggyst's Avatar
Topic started 27 Mar 2015 19:12 by teggyst
Hi there my bonnet wont open on my focus st i was wondering if anyone new where the how to guide was on here has i cant find it thanks
Rich's Avatar
Last Post by Rich 02 May 2015 10:41
Mark @ Automodz says no chance if you have an after market intercooler fitted. Sent from my SM-G900F using Tapatalk
emo
Views: 2625
Replies: 26
Preview
St-cool's Avatar
Topic started 24 Sep 2013 16:42 by St-cool
What's are the symptoms of dodgy driveshafts?
Casper's Avatar
Last Post by Casper 01 May 2015 20:30
Id try where u got it from if you have warranty
emo
Views: 679
Replies: 4
Preview
Heavy Smoker's Avatar
Topic started 15 Apr 2015 10:04 by Heavy Smoker
Need a little help please. St 2008 facelift standard apart from exhaust (boostjunky) Ok popped out last night for a drive. Seem to have a problem on boost 3rd gear. Hit a bit of boost in 3rd then the car seems to what i can only describe as running on 3/4 cylinders. Drove about 1-2miles and it...
Rich's Avatar
Last Post by Rich 26 Apr 2015 10:40
Mine did similar before and was a coil. Sent from my SM-G900F using Tapatalk
emo
Views: 360
Replies: 0
Preview
Hudson1988's Avatar
Topic started 24 Apr 2015 10:37 by Hudson1988
I've recently brought a mk2 st3 and it has developed a metal on metal grinding noise when driving or running it goes away when I put my foot on clutch any ideas??
emo
Views: 437
Replies: 0
Preview
Twiggy15's Avatar
Topic started 20 Apr 2015 17:29 by Twiggy15
Aperently STERING wheel angle 1&2 circuit failure? Any ideas? Cheers Twiggy.
emo
james.carter.75's Avatar
Topic started 11 Apr 2015 21:40 by james.carter.75
Hi all I have recently brought a st225 55plate when I brought it couldnt complain Not a fault with it The next day started it up from cold and the oil pressure light come on and gauge dropped and stayed on for a while I no a little about them so ive replaced the oil filter housing, oil filler cap...
Casper's Avatar
Last Post by Casper 14 Apr 2015 06:43
That doesnt sound very food at all, the light coming up on the dash rules out things like the maf as that light is failsafe where as the gauge isnt. My suggestion would be, check all the connectors on the passenger fusebox for evidence of water ingress. Failing that have the oil pressure tested with...
emo
Views: 227
Replies: 0
Preview
Viksy's Avatar
Topic started 08 Apr 2015 21:10 by Viksy
Driving today and had the esp light and engine light flashing like a flipping disco. They layer.on today heard a big bang from the rear brakes struggling to find the issue any ideas welcomed Thanks
emo
Views: 318
Replies: 5
Preview
TonyST's Avatar
Topic started 07 Apr 2015 09:51 by TonyST
Hi all, My engine management light came on this morning, the car is running fine though. I have a sports cat and a Collins dump valve fitted. Anyone else ever had this? Can anyone locally to me in Stockport read the fault codes? Thanks, Tony Sent from Samsung Mobile using Tapatalk
TonyST's Avatar
Last Post by TonyST 08 Apr 2015 09:25
Thanks everyone. Sent from Samsung Mobile using Tapatalk
emo
Views: 554
Replies: 17
Preview
Viksy's Avatar
Topic started 24 Feb 2015 17:46 by Viksy
Focus st225 pal. Seem to have flat spotting between 3k and 4k revs. yesterday car seemed to be slightly juddering on acceleration like an hesitation. Any ideas, we did find a intercooler pipe that was damaged and have replaced that it's kind of every since then, or maybe that's just coincidence.
Smurfitt's Avatar
Last Post by Smurfitt 31 Mar 2015 20:41
That might be the problem the traction control kicking in when shouldn't. Have you tried turning the esp off and seeing if the flat spot is still there? Or Best bet to get a diagnose on the car there might be a fault code on the ecu that might help Sent from my iPhone using Tapatalk
emo
Views: 318
Replies: 6
Preview
Jamie-st2's Avatar
Topic started 03 Mar 2015 22:29 by Jamie-st2
Basically driving the car normal speed and car just stopped with battery light flashed all electrics are dead on really bright but won't even turn over sounds like the altenator pully and belt is turning ok but just won't start even jump leads on won't start and on bump won't either any ideas...
Bluff's Avatar
Last Post by Bluff 28 Mar 2015 18:11
You have to try and trust these people who are tightening your bolts on your car it's pretty scary :/ Sent from my iPhone using Tapatalk
emo
Views: 480
Replies: 2
Preview
Viksy's Avatar
Topic started 26 Mar 2015 20:15 by Viksy
Symptoms of OEM.recirc valve failing other than whistle noise. Thanks
Rich's Avatar
Last Post by Rich 26 Mar 2015 23:06
I think you would know about it if it had gone..
emo
Views: 396
Replies: 3
Preview
Viksy's Avatar
Topic started 15 Mar 2015 18:39 by Viksy
Hi all Been having a look on the Web and reading about faulty or damaged wheel bearings causing the esp light to illuminate is this correct. Thanks
A and K MOTORSPORT's Avatar
Last Post by A and K MOTORSPORT 17 Mar 2015 09:06
:unsure: It could just be a dodgy wheel speed sensor!
emo
Views: 402
Replies: 0
Preview
Viksy's Avatar
Topic started 11 Mar 2015 09:44 by Viksy
Want to know the common symptoms of the below components, to try and diagnose an issue. Symptoms of faulty boost solenoid Symptoms of faulty OEM recirc valve Symptoms of faulty MAP Sensor Thanks all
emo
Views: 501
Replies: 4
Preview
dockermel's Avatar
Topic started 28 Jan 2015 12:20 by dockermel
:facepalm: hi my :st: 2 is not boosting propley after a few searches I think its the boost solenoid. anyone changed one before?? is it an easy job,can it be done at home?? thanks for any help ;)
Casper's Avatar
Last Post by Casper 01 Mar 2015 21:24
Wtf^ what was that on?
emo
Views: 597
Replies: 12
Preview
Kieranst2's Avatar
Topic started 22 Feb 2015 18:41 by Kieranst2
keep getting power assist failure and engine system fault, ever since having my RS clutch fitted... was happening once in a blue moon but now its got to the point where the car Is undriveable!! running a dcsi induction and dsci map. car drives and sounds fine when it's not playing up but now keeps...
Casper's Avatar
Last Post by Casper 28 Feb 2015 13:59
Bugger, thats becoming irritably common. Its usually the big Green connector at the top right corner, must admit I havent seen those symptoms before, i'll keep that for the memory bank. We usually replace damaged parts and apply a layer of clear contact grease to the pins on the face if the...
emo
Views: 598
Replies: 28
Preview
nick46's Avatar
Topic started 09 Apr 2014 18:39 by nick46
Just had this fault code come up today P0133 "HEATED O2 SENSOR CIRCUIT SLOW RESPONSE". There is quite a bit of background to this, so check out my other thread on P0420 Fault code for all the information (saves me typing it all again!). I'm guessing this is still linked to the 200cell cat i've...
nick46's Avatar
Last Post by nick46 14 Feb 2015 22:40
Quote: A quick one... What stage nap are you? How is your fuel economy..? More thirsty than normal? Also do you have boost issues at all.. Before I removed the Bluefin I was running the stage 2 map and everything was performing as it should. I reinstalled the Bluefin months ago now and the fault has not...
emo
Views: 337
Replies: 1
Preview
SToppard46's Avatar
Topic started 28 Jan 2015 19:19 by SToppard46
Engine light came on, had the code read and said U2023. Looked on the internet and founf communication error between turbo and intercooler. Where do i start to look to fix this and how do i fix this thanks :bow:
Casper's Avatar
Last Post by Casper 28 Jan 2015 21:51
Same code as before mate isn't it Sent from my C6603 using Tapatalk
emo
Views: 341
Replies: 8
Preview
jmwood21's Avatar
Topic started 20 Jan 2015 10:22 by jmwood21
I have a 60plate st2 on 28500 miles and between 1500-2000 revs I have a tapping noise, it's been to ford and had the flywheel changed and spark plugs but still had the same problem, any ideas? thanks
Casper's Avatar
Last Post by Casper 20 Jan 2015 22:07
As above^ Sent from my C6603 using Tapatalk
emo
Views: 256
Replies: 4
Preview
Olly's Avatar
Topic started 03 Dec 2014 15:35 by Olly
As title really, my bumper has started vibrating/knocking on my exhaust tip almost as tough the bumper has dropped slightly, that or the exhaust is pulled up. Any ideas?
Mark's Avatar
Last Post by Mark 08 Jan 2015 22:43
OIly has the front of the bumper started to touch the arch if so get under and undo the bolts on the white brackets push up the bumper while tightening the bolts back up again Sent from my iPhone using Tapatalk
emo
Views: 472
Replies: 2
Preview
Jacka011's Avatar
Topic started 01 Dec 2014 20:41 by Jacka011
Can someone please help me !!! My car is standard apart from a bigger intercooler. When i accelerate the boost guage goes to 1/4 of the way and doesnt move it takes ages to get high revs and the needle still doesnt move!! Can someone please tell me why it isnt going full boost ??
ST-McFarlane's Avatar
Last Post by ST-McFarlane 07 Jan 2015 18:45
Does the turbo sound like its spooling up properly just not boosting.? does the car stutter and have you any codes pending or come up?
emo
Views: 383
Replies: 11
Preview
Olly's Avatar
Topic started 03 Dec 2014 15:41 by Olly
Had this for quite a while now, happened after a visit to ford around a year or two ago for a service but was so rare it didn't cross my mind and put it down to maybe a too thin oil? now it's grtting more frequent, I'd like to think it's a loose boost hose, have done some reading around and a few...
Casper's Avatar
Last Post by Casper 12 Dec 2014 18:38
I was thinkin that, wonderd if they'd already been done
emo
Views: 333
Replies: 9
Preview
Viksy's Avatar
Topic started 05 Dec 2014 04:44 by Viksy
Well I'm without a car again. Oil filter housing decided to go on my journey out Monday. Got recovered to the garage. Where its waiting to be repaired. Where did you get your parts from? Volvo or Ford? Thanks all
A and K MOTORSPORT's Avatar
Last Post by A and K MOTORSPORT 10 Dec 2014 12:49
:thumbsup: You dont need to remove it completely. Disconnect the hoses and pull it up out of its mounts then just move it across to the right.
emo
Views: 352
Replies: 2
Preview
Viksy's Avatar
Topic started 05 Dec 2014 20:36 by Viksy
Got this code stored in the car when the cars codes are read. Could the dumpvalve be causing this is heard you can get air leaks from them. Hopefully removing tomorrow if we can get something to fit for the time being.
Rich's Avatar
Last Post by Rich 05 Dec 2014 23:38
If you want help removing let me know I'm only a text away :).
emo
Views: 389
Replies: 12
Preview
Viksy's Avatar
Topic started 14 Oct 2014 15:06 by Viksy
I've noticed a squeal noise when turning sharp or full lock left or right. But javelin no idea what it could be any ideas
Viksy's Avatar
Last Post by Viksy 27 Oct 2014 22:21
no leaks to what i can see. Just the gear change clunking as got alot worse in most gears now

PM Center

You are not logged in.

  • Total Users: 10.27k
  • Latest Member: britt.dudley
  • Total Posts: 46.3k
  • Total Topics: 6457
  • Total Sections: 38
  • Total Categories: 412
  • Today Open: 2
  • Yesterday Open: 0
  • Today Answer: 24
  • Yesterday Answer: 10

CLUB BIRTHDAYS

Events Calender

September 2017
S M T W T F S
27 28 29 30 31 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30